Главная сайта | Форум | Фотоальбом | Регистрация   | Вход | Cайт в избранное | Правила сайта и форума

Приветствую Вас Гость | RSS | Telegram канал


Фильмы | Онлайн Видео | Софт | Новости и Статьи | Игры онлайн | Фотоальбом | Форум

ДЛЯ ПРОСМОТРА САЙТА РЕКОМЕНДУЕТСЯ ИСПОЛЬЗОВАТЬ:  Uran - браузер от uCoz на базе проекта Chromium. | Google Chrome | Opera | Firefox 


МЕНЮ САЙТА

ПОИСК ПО САЙТУ

Путешествие к бессмертию: Глава 596-600

Путешествие к бессмертию: Глава 591-595

Путешествие к бессмертию: Глава 586-590

Путешествие к бессмертию: Глава 581-585

Путешествие к бессмертию: Глава 576-580

Путешествие к бессмертию: Глава 571-575

Путешествие к бессмертию: Глава 566-570

Путешествие к бессмертию: Глава 561-565

Путешествие к бессмертию: Глава 556-560

Путешествие к бессмертию: Глава 551-555

Во что поиграть на этой неделе — 31 августа + Лучшие скидки на игры

Во что поиграть на этой неделе — 14 декабря + Лучшие скидки на игры

Игромания! Игровые новости, 29 февраля (Half-Life 3, Nintendo, HTC Vive, Uncharted 4)

Во что поиграть на этой неделе — 21 сентября + Лучшие скидки на игры

Игромания! ИГРОВЫЕ НОВОСТИ, 22 июля (Switch Lite, Stadia, Uplay+, Watch Dogs Legion, Overwatch)

Игромания! ИГРОВЫЕ НОВОСТИ, 14 января (S.T.A.L.K.E.R. 2, Resident Evil 3, Корсары)

Во что поиграть на этой неделе — 12 октября + Лучшие скидки на игры *ОБНОВЛЕНО*

Во что поиграть на этой неделе — 27 мая (Overwatch, Total War: Warhammer)
СТАТИСТИКА
Всего материалов:
Фильмомания: 1639
Видео: 220
Каталог файлов: 95
Каталог статей: 7660
Фотоальбом: 1236
Форум: 1198/9408
Каталог сайтов: 387

Всего зарегистрировано:
Зарегистрировано: 1859
Сегодня: 0
Вчера: 1
За неделю: 1
За месяц: 5

Из них:
Пользователи: 1785
Проверенные: 23
Друзья: 5
Редакторы: 0
Журналисты: 8
В вечном бане: 33
Модераторы: 0
Администраторы: 3

Из них:
Парней 1364
Девушек 493


ON-Line всего: 1
Гостей: 1
Пользователей: 0

Сейчас на сайте:


День Рождения у: Tom(39), nPwka(34)
ВЫ МОЖЕТЕ ОКАЗАТЬ ПОДДЕРЖКУ ЗА ТРУДЫ, ПОЖЕРТВОВАВ ЛЮБУЮ СУММЫ.

WEBMONEY



Категории каталога

Главная » Статьи » Статьи » Статьи: Windows 7

Администрирование » Службы Windows 7 Simple TCP/IP Services – что и как?

Службы Windows 7 Simple TCP/IP Services представляют собой набор инструментов, которые могут помочь сетевым администраторам. Полезны они или нет – это отдельный вопрос, но вы в любом случае должны знать о том, что они собой представляют и где их найти. Недавно я просматривал посты на веб форуме, и новый пользователь спрашивал о службах TCP/IP Simple Services. Он говорил о том, что на его машине эти службы были включены, и ему было интересно, что они собой представляют, был ли это вирус, представляют ли они риск для безопасности. Прежде всего, это не вирус. Службы Simple TCP/IP Services существовали в Windows, сколько я себя помню (ну, или, по крайней мере, с Windows NT). Но что это такое? Позвольте мне показать вам, как их устанавливать, что они могут делать и как они могут вам помочь.

Что такое Simple TCP/IP Services?

Simple TCP/IP Services – это набор утилит командной строки. Этот набор включает протоколы "quote of the day", daytime, протокол генератора символов (chargen), протокол echo и discard.

На самом деле, это порты, которые открываются на вашем компьютере Windows для выполнения определенных диагностических функций и тестов. Они не используются никакими известными мне программами, и не представляют собой инструменты для ежедневного использования.

Давайте выполним каждый протокол/службу и посмотрим, что каждый из них делает (как говорится в Microsoft TechNet):

Quote of the Day (QOTD) - основан на RFC 865 - использует порт 17 – возвращает цитаты в виде одной или нескольких текстовых строк в сообщении. Цитаты выбираются случайно из следующего файла: systemroot\System32\Drivers\Etc\Quotes. Примерный файл цитаты устанавливается с Simple TCP/IP Services. Если этот файл отсутствует, данная служба не работает.

Вот что я получил, когда выполнил тест

telnet localhost 17

*
Увеличить

Рисунок 1

Daytime - основан на RFC 867 - использует порт 13 – возвращает сообщения, содержащие день недели, месяц, год, текущее время (в формате hh:mm:ss), а также информацию о часовом поясе. Некоторые программы могут использовать результаты этой службы для отладки и мониторинга изменений времени системных часов или на другом узле.

Результаты команды telnet localhost 13

*

Рисунок 2

Character Generator (chargen) - основан на RFC 864 - использует порт 19 – отправляет данные, состоящие из 95 печатных ASCII символов. Используется в качестве инструмента отладки для тестирования или диагностики принтеров.

Если вы введете telnet localhost 19, то получите

*
Увеличить

Рисунок 3

Вам нужно будет нажать CTRL-], затем ввести quit, чтобы прекратить это беспрерывное прокручивание символов (или завершить процесс командой строки).

Echo - основан на RFC 862 - использует порт 7 – возвращает данные эха любого сообщения, которые получает на этот порт сервера. Эхо может быть полезным в качестве инструмента мониторинга и отладки сети.

Ввод telnet localhost 7 выдаст вам

*

Рисунок 4

На самом деле, эта служба просто возвращает вам эхом все, что вы вводите.

Discard - основан на RFC 863 - использует порт 9 – удаляет все сообщения, принятые на этот порт без ответа и подтверждения. Может использоваться в качестве null порта для получения и пересылки TCP/IP тестовых сообщений во время настройки сети или в некоторых случаях может использоваться программами в качестве функции удаления сообщения.

Попытка подключения к этому порту через протокол Telnet не даст вам НИКАКИХ результатов, поскольку все отправленное на этот порт удаляется.

Как включать или выключать Simple TCP/IP Services?

Чтобы включить или выключить службы simple TCP/IP services, вам нужно перейти в панель управления (Control Panel), программы (Programs), а затем включить или выключить функции Windows (Windows Features). Вам не нужно устанавливать никаких приложений.

Здесь отмечаете флажком Simple TCP/IP Services, как показано на рисунке ниже.

*

Рисунок 5

Для установки этой службы потребуется всего несколько секунд.

*

Рисунок 6

После установки вы вернетесь обратно в окно Программы (Programs). Не будет никаких уведомлений об успешной установке этих служб. После установки simple TCP/IP services вы не сможете включать или отключать отдельные службы. Другими словами – «это все или ничего».

Если вы хотите начать использовать службы прямо сейчас, вам нужно будет перейти в оснастку Службы (Services) в консоли и Запустить службу.

Запуск этих служб отмечен как автоматический, поэтому они будут автоматически запускаться после следующей перезагрузки машины, но в первый раз вы должны запустить их вручную, если не собираетесь перезагружать компьютер.

*

Рисунок 7

Как отключать службы? Все очень просто, нужно выполнить действия, противоположенные тем, которые я описал выше. Вам нужно остановить (Stop) службу, затем перейти в список Windows Features и убрать флажок с этой службы. Это отключит службу и деинсталлирует ее.

Чем Simple TCP/IP Services могут быть полезны?

Сегодня службы simple TCP/IP services имеют ограниченную сферу применения. Вот несколько идей по их применению, которые пришли мне в голову:

  1. Обучение - эти службы уходят корнями в Linux / Unix и существуют уже очень давно. Возможно, вы сдаете какой-либо тест, в котором вам нужно знать все о сетевых фикциях. Возможно, вам просто интересно и вы хотите получить опыт работы со всеми возможными сетевыми функциями и протоколами TCP/IP. В любом случае, для работы с simple TCP/IP services требуется совсем немного времени.
  2. Тестирование - возможно, вам нужно включить эти функции на машине, которая находится на брандмауэре, а затем протестировать открывание портов на этой машине.

Не важно, в каких целях вы будете использовать эти службы, я рекомендую отключать их по завершении работы с ними, поскольку любой открытый порт представляет риск для безопасности.

Заключение

Мы рассмотрели, что собой представляют службы Windows 7 Simple TCP/IP Services и как они могут вам помочь. Эти службы на самом деле представляют собой ряд утилит командной строки, которые могут быть полезны сетевым администраторам. Независимо от того, будут ли они полезны или нет, вы, по крайней мере, должны знать, что они собой представляют, и где их найти. И в ответ аскеру форума можно с уверенностью сказать – нет, это не вирус :)

 

Автор: Дэвид Дэвис

Источник http://www.redline-software.com/rus/


Если на странице вы заметили в посте отсутствие изображений, просьба сообщить , нажав на кнопку.



После прочтения материала " Администрирование » Службы Windows 7 Simple TCP/IP Services – что и как? ", можно просмотреть форум и поискать темы по данной игре.



ДРУГИЕ МАТЕРИАЛЫ
Европейцам предложат Windows 7 с десятью браузерами
Самое популярное занятие пользователей Рунета – чтение новостей
Загадка зевоты
Некоторая информация о новой части Tomb Raider
Троян-вымогатель станет распространяться быстрее
Новые возможности: 10 новых функций в сетевых параметрах Windows 7
FAQ по Windows Vista: Разное
Актив и пассив: две видеокарты MSI GeForce 9400 GT
ICQ рассылает нового "трояна"
На дне марсианских кратеров обнаружен лед
Видео-презентация Splinter Cell Conviction с PAX 2009
Эпический трейлер Tomb Raider Underworld
Покупателей The Pirate Bay выгнали с биржи
"Есть покрытие!" - новый проект от компании «Доктор Веб»
Computex 2009: Intel делает ставку на CULV-ноутбуки
Защита и восстановление системы в Windows 7
ПК-версия ролевой игры Risen отправлена на золото
Яркая замена Diablo 3 под названием Torchlight
Музыкальный трейлер игры Dungeons & Dragons Online
Поклонники Halo 3 засудят Microsoft и Bungie

Если вам понравился материал "Администрирование » Службы Windows 7 Simple TCP/IP Services – что и как?", - поделитесь ним с другими.


html-cсылка на публикацию
BB-cсылка на публикацию
Прямая ссылка на публикацию


Категория: Статьи: Windows 7 | Добавил: Фокусник (18.03.2010)
Просмотров: 1990

Ниже вы можете добавить комментарии к материалу " Администрирование » Службы Windows 7 Simple TCP/IP Services – что и как? "

Внимание: Все ссылки и не относящиеся к теме комментарии будут удаляться. Для ссылок есть форум.


Всего комментариев : 0
avatar
ФОРМА ВХОДА
ПОЖЕРТВОВАНИЯ

WMZ: Z143317192317

Boosty - Donate

Payeer: P48650932
На кофе / ko-fi
На пиво / wayforpay
ПАРТНЕРЫ

World of Warships — это free-to-play ММО-экшен, который позволяет окунуться в мир масштабных военно-морских баталий. Возьмите под управление легендарные боевые корабли первой половины ХХ века и завоюйте господство на бескрайних океанских просторах.

Курсы обмена WebMoney


Что такое ресурс Turbobit и как качать.




Получи 10 ГБ места бесплатно, на всю жизнь.


Boosty – сервис по сбору донатов.
Batman: Arkham Knight
Batman: Arkham Knight
Бильярдные трюки
Бильярдные трюки
Поющие Трусы - Пластический Хирург
Поющие Трусы - Пластический Хирург
Слухи и новости о 14 сезоне сверхъестественного!
Слухи и новости о 14 сезоне сверхъестественного!
Драка на Молодежной улице
Драка на Молодежной улице
Подборка неудач за июль 2011
Подборка неудач за июль 2011
Игрозор №188
Игрозор №188
Сингла в Fallout 76 не будет, GTA VI в 2019, когда выйдет PS5, Call of Duty 2019, Shenmue 3
Сингла в Fallout 76 не будет, GTA VI в 2019, когда выйдет PS5, Call of Duty 2019, Shenmue 3
Xenonauts 2 на Kickstarter, откровения FIFA 18, слив презентации Cyberpunk 2077, новая Scrolls...
Xenonauts 2 на Kickstarter, откровения FIFA 18, слив презентации Cyberpunk 2077, новая Scrolls...
50 лучших игр E3 2018. Часть 2/5
50 лучших игр E3 2018. Часть 2/5

9-летняя австралийка пародирует знаменитостей, используя повседневные предметы (25 фото)
9-летняя австралийка пародирует знаменитостей, используя повседневные предметы (25 фото)
Свежая коллекция демотиваторов (18 фото)
Свежая коллекция демотиваторов (18 фото)
Оружие из деталей пишущих машинок
Оружие из деталей пишущих машинок
Атмосферные фотографии заброшенного транспорта и кладбищ автомобилей (14 фото)
Атмосферные фотографии заброшенного транспорта и кладбищ автомобилей (14 фото)
Субботний пост приколов (21 шт)
Субботний пост приколов (21 шт)
15 фотографий спасённых от бездомной жизни животных, которые вернут вам веру в человечество
15 фотографий спасённых от бездомной жизни животных, которые вернут вам веру в человечество
Пляжные будни в прикольных картинках (17 фото)
Пляжные будни в прикольных картинках (17 фото)
Художник изобразил диснеевских персонажей в виде реальных людей (17 фото)
Художник изобразил диснеевских персонажей в виде реальных людей (17 фото)
СТАТИСТИКА
Яндекс.Метрика


Copyright © 2000-2026, Alex LTD and System PervertedХостинг от uCoz